Home » Infrastructure » Windows » ORACLE NT service starting problem TNS-12514
ORACLE NT service starting problem TNS-12514 [message #99478] Tue, 27 November 2001 15:56 Go to next message
F.Burgisser
Messages: 2
Registered: November 2001
Junior Member
I'm using ORACLE 8.1.6 on NT5.
The service as the status "starting" every time.
I can start the database with the svrgmrl but it doesn't solve my problem because I don't want to start it manually every time.
It was working fine before.
I deleted the trace files but nothing changed.
Before this problem happen I just updated Norton Anti-virus. I think there isn't any realtion but I'm not sure. I can't figure out the problem. The configuration didn't changed.

Any ideas?

Thanks

----------------------------------------------------------------------
Re: ORACLE NT service starting problem TNS-12514 [message #99550 is a reply to message #99478] Mon, 07 January 2002 03:21 Go to previous messageGo to next message
Anu
Messages: 82
Registered: May 2000
Member
I was facing the same problem since I system got affected my Nimbda virus!! After fixing the virus, I could able to start it properly.
Re: ORACLE NT service starting problem TNS-12514 [message #99554 is a reply to message #99550] Mon, 07 January 2002 17:02 Go to previous messageGo to next message
F.Burgisser
Messages: 2
Registered: November 2001
Junior Member
Thanks for your reply.
I didn't have been infected by Nimbda. I solved the problem by recreating the entire database (then the service too). This is the only solution I found...

F.Burgisser
Re: ORACLE NT service starting problem TNS-12514 [message #101371 is a reply to message #99478] Thu, 02 September 2004 08:01 Go to previous message
Lalit Kumar
Messages: 2
Registered: September 2004
Junior Member
I was getting the same error. I was able to TNSPING and also connect using SQLPLUS when I did not give the HOST_STRING.

My environment is :
Windows XP Prof, Oracle Version 9.2.0.1.0. But I guess conceptualy it will be same for other versions too.

This is what I found after looking at various sites and doing many tries.

This error was coming due to mismatch in the SERVICE_NAME given in tnsnames.ora and what was registered with the listener. Actually, listener is comparing the connect SERVICE_NAME passed from client site to the one registered with it. If nothing matches, it gives TNS-12514.

To check if they are the same, do the following:

1. run "LSNRCTL services" to check the services names registered with oracle. For example if one of the database service name is "LKDW" (which could be Oracle SID for Oracle 8.xx)

2. Make sure that this is the service name (i.e. "LKDW") in tnsnames.ora if you are using Oracle 9.xx type specs or you specify SID as "LKDW" for Oracle 8 type connections. Example is given below.

Output of "lsnrctl services"----> (Note the LKDW)
--------------------------------
LSNRCTL> services
Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=fujisap)(PORT=1521)))
Services Summary...
Service "LKDW" has 1 instance(s).
Instance "LKDW", status READY, has 1 handler(s) for this service...
Handler(s):
"DEDICATED" established:0 refused:0 state:ready
LOCAL SERVER
Service "LKDWXDB" has 1 instance(s).
Instance "LKDW", status READY, has 1 handler(s) for this service...
Handler(s):
"D000" established:0 refused:0 current:0 max:1002 state:ready
DISPATCHER <machine: FUJISAP, pid: 1136>
(ADDRESS=(PROTOCOL=tcp)(HOST=fujisap)(PORT=3875))
Service "PLSExtProc" has 1 instance(s).
Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
Handler(s):
"DEDICATED" established:0 refused:
LOCAL SERVER
The command completed successfully
LSNRCTL>
----------------------------

Output of tnsnames.ora (for Oracle 8i type connections)
---------------------------------
LKDW =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = FUJISAP)(PORT = 1521))
)
(CONNECT_DATA =
(SERVICE_NAME = lkdw)
)
)
----------------------------

OR if using oracle 8 type connection string:

----------------------------
LKDW =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = FUJISAP)(PORT = 1521))
)
(CONNECT_DATA =
(SID = LKDW)
)
)
--------------------------

I was giving a different name than "LKDW" in tnsnames.ora and I was getting TNS-12514 error.
Previous Topic: Connectivity
Next Topic: MS Access & SQL passthru error - invalid precision for decimal data type
Goto Forum:
  


Current Time: Fri May 27 01:01:33 CDT 2022