Home » Developer & Programmer » Precompilers, OCI & OCCI » Getting Error : unable to open include files (ProC/C++,32 bit os,32 bit oracle,linux)
Getting Error : unable to open include files [message #334294] Wed, 16 July 2008 02:04
Messages: 1
Registered: July 2008
Junior Member
Hi all,
I am new to ProC/C++.
I am going through some demo programs.
I tried to link using make -f demo_proc.mk sample1
I tried to compile using proc sample1.pc
In both commands i am getting error like---
unable to open include file, unable to open list file for some .h files...
Can anybody tell me what is the reason and please tell solution also...

Issues i found out....that could be a problem as
1. there is no
"spnc_commands" file in OracleHome/plsql/ location...."spnc_commands" contains the templates for the commands to compile and link the program.

2. There is no folder /precomp/include

3... I have got some other specification also...
.pc pgm is having #include <stdio.h>
which refers to /usr/include/stdio.h
if /usr/include/stdio.h has #include <stddef.h>
compiler is not able to open stddef.h file..
as /usr/include/stddef.h is not there and apart of this /usr/include/stdarg.h is not there...........
please tell me what can be done..


[Updated on: Thu, 17 July 2008 00:14]

Report message to a moderator

Previous Topic: Segmentation Fault
Next Topic: abort (coredump) with OCCI
Goto Forum:

Current Time: Thu Dec 02 03:54:27 CST 2021